Back to overview
Downtime

AWS outage

Oct 19 at 10:40pm HDT
Affected services
Dashboard
US API
WorkOS
Orb Billing

Resolved
Oct 20 at 01:00pm HDT

AWS has now fully recovered its systems and trigger queues in our US region are now fully operational. All Relevance systems have now fully recovered.

See https://health.aws.amazon.com/health/status for AWS's full timeline of the incident and mitigation efforts.

Updated
Oct 20 at 02:24am HDT

AWS is working on a full recovery for compute capacity issues which are still experiencing elevated error rates. This is the underlying cause of trigger queues not processing in the US region. All other services are performing as expected.

Updated
Oct 20 at 01:53am HDT

Trigger queue processing in the US region remains degraded due to a slow recovery of capacity on AWS's side. All other services appear to be running as expected.

Updated
Oct 20 at 12:40am HDT

Services are back up and running as AWS has begun mitigation of the outage. Login to the Relevance platform is now available and the US region is running agent tasks successfully. Some errors may still occur as AWS continues its mitigation efforts and capacity recovers in the affected region.

Created
Oct 19 at 10:40pm HDT

Amazon Web Services is having major operational issues affecting multiple services in its us-east-1 region. Our US services are hosted in this region, and it also serves as a core piece of AWS's global infrastructure. This outage also appears to be affecting many other services, including our login provider and our frontend web host. As a result, access to the Relevance platform is heavily degraded.

Our EU and AU services are unaffected and scheduled tasks are running in those regions. However, users in those regions are still unable to login or access the platform due to the AWS outage, and the outage may also affect agent performance, especially for agents using data sourced from services hosted by AWS.

AWS status page: https://health.aws.amazon.com/health/status