Back to overview
Degraded

Trigger Visibility Issue in Platform UI

Jun 19, 2026 at 1:53am UTC
Affected services
Agent Builder

Resolved
Jun 19, 2026 at 4:12am UTC

The issue has been resolved and trigger visibility has been restored. Thank you for your patience while we worked to resolve this issue.

Updated
Jun 19, 2026 at 4:04am UTC

The fix has been successfully applied across all affected regions. Trigger visibility in the platform UI has been restored, and we are actively monitoring the platform to ensure stability and confirm full resolution of the issue.

Created
Jun 19, 2026 at 1:53am UTC

We are currently investigating an issue where some triggers are not appearing in the platform UI. While this may make it seem like a trigger has been removed, triggers continue to run normally and no trigger data has been lost. Our team is actively working to restore visibility in the UI and will provide updates as progress is made.