Back to overview
Degraded
Unable to add custom filtering for knowledge tools
Mar 27, 2026 at 12:39am UTC
Affected services
Agent Builder
Resolved
Mar 27, 2026 at 3:48am UTC
We have deployed the fix to production and have verified custom filtering for knowledge tool steps has been restored. Apologies for the inconvenience.
Affected services
Updated
Mar 27, 2026 at 1:52am UTC
A fix has been purposed and is being verified our development environment.
Affected services
Created
Mar 27, 2026 at 12:39am UTC
Our tool builder has removed the option for applying custom filters to knowledge tool steps. We have found the root cause and the team are implementing a fix.
Workaround: You can still apply customer filters by switching to manual edit mode for the filter value.
Affected services