Back to overview
Downtime

[Region US] Modal Python Steps Experiencing Service Outage

May 8, 2026 at 1:29am UTC
Affected services
Modal

Resolved
May 8, 2026 at 5:11am UTC

The issue affecting Modal Python tool steps has been resolved, and services are now operating normally.

Updated
May 8, 2026 at 2:19am UTC

We have swapped all new task runs on our backup python execution infra. We are monitoring the situation. Existing tasks need to be re-run if they are stalled.

Created
May 8, 2026 at 1:29am UTC

An ongoing AWS outage in the US region is currently causing disruptions to Modal Python tool steps on our platform, as Modal’s infrastructure is hosted on affected AWS services.